Light Style© by Fisana

Vai al contenuto

  •  

Foto
- - - - -

database di Trainz 12


  • Per cortesia connettiti per rispondere
13 risposte a questa discussione

#1 gigimori

gigimori

    apprendista stregone

  • Gold Member
  • 1419 messaggi
  • LocationPiacenza

Inviato 27 agosto 2017 - 04:25

da qualche tempo mi capita troppo spesso che il mio trainz parte (!) per un db-recovery

 

Allega File  6.png   90,67KB   0 Numero di downloads

 

...lungo e laborioso...

 

non ci sono motivazioni concrete apparenti;

in questo caso ho caricato il cdp dei carri scoperti, ha fatto il download in Auran di "TYind Steel slab" che è necessario, ho anche visto un carro in "deposito"... prendo la sigaretta, cambio il filtro da "oggi" a "installati" e............. ora sono alla seconda e fumare fa male..  :lol:  :lol:  :lol:

 

altre volte chiudo regolarmente e quando lo riapro prima di poter fare qualcosa "assest remaing to validate...."

 

ho sempre aperti i "prompt dei comandi" di trainz per attendere la chiusura delle operazioni prima di spegnere il pc.

 

il dubbio:

 

non è che magari il db avrà bisogno di una manutenzione? E' tanto tempo che è installato su questo pc...

Esiste qualcosa come un "purge", un "db-defrag" una utility che và eseguita ogni tanto?

 

grazie dell'interessamento come sempre

 

ggmr

 

EDIT: qualcosa che non sia la riparazione rapida (che sta eseguendo) o estesa...  ;)


Messaggio modificato da gigimori, 27 agosto 2017 - 04:26

kuid:184123 - TS12 SPK1 Build 59009 (e rimane tale...)

#2 pegaso52

pegaso52

    Cab Mode

  • Gold Member
  • 3022 messaggi
  • LocationGranducato di Toscana o meglio FEDERAZIONE ETRUSCA

Inviato 27 agosto 2017 - 04:42

Il taddaemon è quel marchingegno che ogni tanto fa girare i cosiddetti.

 

Se sulla barra in basso si sono chiuse tutte le finestre, dovreste averne 2 una come quella in immagine e un'altra che segnala le elaborazioni e possono essere almeno 4 sovraesposte.

 

Se queste cartelle sono sparite tutto a posto. Fai un rapido repair database e dovrebbe sistemarsi.

 

ATTENZIONE, non fagli fare l'esteso repair perchè si mangia alcuni file.

 

Per quanto riguarda il validate lascialo correre, qualche volta me ne trovo 2000 senza logica apparente.

 

Facci sapere.


Pier Luigi Kuid 519059
TS 10 Build 49933
TS 12+SP1 Build 61388 Collectors' edition n° 970
T:ANE CE SP3 Build 94916
TRS 2019 Build 97556


#3 gigimori

gigimori

    apprendista stregone

  • Gold Member
  • 1419 messaggi
  • LocationPiacenza

Inviato 27 agosto 2017 - 05:21

.... 2 una come quella in immagine e un'altra che segnala le elaborazioni e possono essere almeno 4 sovraesposte.

Se queste cartelle sono sparite tutto a posto. Fai un rapido repair database e dovrebbe sistemarsi.

ATTENZIONE, non fagli fare l'esteso repair perchè si mangia alcuni file.

 

Per quanto riguarda il validate lascialo correre, qualche volta me ne trovo 2000 senza logica apparente.

 

Facci sapere.

 

si si, quando lo esegue, 2 o 3 e anche 4 come dici tu taddaemon aperti... poi finisce e tutto a posto;

con il validate di 1800-2000 assets però non si può fare nulla se non attendere che finisca di... correre  :D

 

per carità mai fare il ripara esteso, imposta tutto come piace a lui  :angry:

il rapido però serve a poco, fatto recentemente e comunque oggi...

 

(vero anche che ho un 100naio di salvataggi progressivi di tratte e se mi mancava qualche dip. per ognuna lo rimarca... dovrei fare un po di pulizia... :computer: ) 

 

da li la domanda se per caso esiste un'altro strumento del quale non sono a conoscenza...

 

;) tks... ggmr


kuid:184123 - TS12 SPK1 Build 59009 (e rimane tale...)

#4 pegaso52

pegaso52

    Cab Mode

  • Gold Member
  • 3022 messaggi
  • LocationGranducato di Toscana o meglio FEDERAZIONE ETRUSCA

Inviato 27 agosto 2017 - 06:19

Per il momento l'unico strumento di mia conoscenza è come hai detto alleggerire il db savando in cdp, poi eòliminare. E' naturale che i cdp siano catalogati con cura e riposti in un HD magari esterno.


Pier Luigi Kuid 519059
TS 10 Build 49933
TS 12+SP1 Build 61388 Collectors' edition n° 970
T:ANE CE SP3 Build 94916
TRS 2019 Build 97556


#5 gigimori

gigimori

    apprendista stregone

  • Gold Member
  • 1419 messaggi
  • LocationPiacenza

Inviato 27 agosto 2017 - 06:52

ehehehhe pegaso.. volevo darti un "Mi piace" ma ho raggiunto la quota dei voti positivi....

 

oggi mi piace tutto  :D  :D  :D  :D  :D

 

gg


kuid:184123 - TS12 SPK1 Build 59009 (e rimane tale...)

#6 gigimori

gigimori

    apprendista stregone

  • Gold Member
  • 1419 messaggi
  • LocationPiacenza

Inviato 30 agosto 2017 - 07:01

ma che sbriciolamento di....

oramai ogni volta che lo apro...

 

Allega File  1.png   139,48KB   0 Numero di downloads

 

aspetta aspetta...  :mah:

 

e questa volta è progressivo.. a salire: 473 - 485 - 494 - 502  :huh:

 

 


kuid:184123 - TS12 SPK1 Build 59009 (e rimane tale...)

#7 sidew

sidew

    Saboteur

  • Gold Member
  • 3125 messaggi

Inviato 30 agosto 2017 - 07:31

Quando chiudi trainz. apri gestione risorse e cerca il processo TADaemon e aspetta a spegnere il PC finche questo processo non si e' terminato da solo.

 

Come gestione DB auran è riuscita a fare peggio di Oracle, ho visto cose che voi umani non sapete....


Aldo aka Sidewinder - kuid: 311961 userid: sidew -  trainz.png
4.png
____________________________________

"I used to be a trainzdiriver like you... then I took an arrow in the knee"
"Oops!" - Shannon Foraker, Ashes of Victory

__________________________________________


#8 gigimori

gigimori

    apprendista stregone

  • Gold Member
  • 1419 messaggi
  • LocationPiacenza

Inviato 30 agosto 2017 - 07:38

ho sempre aperto il prompt dei comandi di tadaemon proprio per aspettare il fatidico "closing database..."

(opzioni / sviluppatore)

 

Allega File  2.png   75,64KB   0 Numero di downloads

 

e il pc è praticamente sempre acceso; è che devo decidermi a cancellare un po di roba e poi fare un recovery breve (incrociando anche le dita dei piedi)

 

vabbè  ;)

 

ciao e grazie

gigimori


kuid:184123 - TS12 SPK1 Build 59009 (e rimane tale...)

#9 UP844

UP844

    Missing in Action

  • Administrators
  • 25721 messaggi
  • LocationSulla cattiva strada

Inviato 02 settembre 2017 - 01:10

Anche TS2010 non è da meno, quando ci si mette...

 

Allega File  please_wait.jpg   658,24KB   0 Numero di downloads

 

 


And gentlemen in England now a-bed
Shall think themselves accursed they were not here
 
UP844 - KUID: 69593 - Author ID: Pendolino - Join Date: Aug 1, 2002
TS2010 build 49933:   morte_benedico

 TS12 build 61388 Collectors' Edition #405  :uè2:

 T:ANE: no, grazie! (ecco perché)  :impiccato:

TRS19: appena uscirà ufficialmente :mrgreen:


#10 UP844

UP844

    Missing in Action

  • Administrators
  • 25721 messaggi
  • LocationSulla cattiva strada

Inviato 02 settembre 2017 - 01:19

:offtopic:

 

Confesso di essere il responsabile della scritta "In folle" sull'interfaccia italiana di TS12.

 

Quando tradussi (in parte) l'interfaccia per TS2009, Auran mi mando degli enormi fogli Excel, ma senza alcuna indicazione di dove le varie stringhe sarebbero state visualizzate (pratica abbastanza comune nella localizzazione del software, che spesso provoca casi ridicoli come questo). Trovando "Idle", che ha diverse possibili traduzioni in italiano, chiesi chiarimenti ai canguri, senza ricevere risposta (non che me ne aspettassi una).

 

Pensando alla guida in cabina, tradussi "in folle", ma all'uscita della beta successiva mi resi conto con orrore che la stringa "Idle" in questione era quella del Content Manager, dove la traduzione corretta sarebbe stata "Inattivo". Nonostante l'invio immediato di mail e di MP, non si sono mai presi la briga di correggere l'errore, che continua a perseguitarmi ogni volta che vedo un Content Manager in italiano :(. Meno male che i miei clienti non giocano a Trainz (spero :D).

 

:ciao:


And gentlemen in England now a-bed
Shall think themselves accursed they were not here
 
UP844 - KUID: 69593 - Author ID: Pendolino - Join Date: Aug 1, 2002
TS2010 build 49933:   morte_benedico

 TS12 build 61388 Collectors' Edition #405  :uè2:

 T:ANE: no, grazie! (ecco perché)  :impiccato:

TRS19: appena uscirà ufficialmente :mrgreen:


#11 DavideEos

DavideEos

    TrainZItalia Friend

  • Gold Member
  • 463 messaggi
  • LocationTreviso

Inviato 02 settembre 2017 - 06:39

:offtopic:

 

Confesso di essere il responsabile della scritta "In folle" sull'interfaccia italiana di TS12.

 

Quando tradussi (in parte) l'interfaccia per TS2009, Auran mi mando degli enormi fogli Excel, ma senza alcuna indicazione di dove le varie stringhe sarebbero state visualizzate (pratica abbastanza comune nella localizzazione del software, che spesso provoca casi ridicoli come questo). Trovando "Idle", che ha diverse possibili traduzioni in italiano, chiesi chiarimenti ai canguri, senza ricevere risposta (non che me ne aspettassi una).

 

Pensando alla guida in cabina, tradussi "in folle", ma all'uscita della beta successiva mi resi conto con orrore che la stringa "Idle" in questione era quella del Content Manager, dove la traduzione corretta sarebbe stata "Inattivo". Nonostante l'invio immediato di mail e di MP, non si sono mai presi la briga di correggere l'errore, che continua a perseguitarmi ogni volta che vedo un Content Manager in italiano :(. Meno male che i miei clienti non giocano a Trainz (spero :D).

 

:ciao:

Mi ero sempre chiesto chi avesse fatto la traduzione in italiano, di quel termine, ora è saltato fuori il "colpevole"!! :P  :P  :P  :P


Davide G Trainz ID: Desertrt Kuid:407509 TRS2006 TS12 Build 59009 T:ANE Deluxe Edition Build 88364 su Win7 Ultimate 64 Bit
AIUTO MORO, PORTEME IN CANEVA, DEME UN LITRO DE CHEL BON...........  :rido:  :rido: 
Canon EOS 6D e 5D Mark IV con 24-105 F4, 70-200 F2.8, 85 1.2, 16-35 2.8 Tamron 150-600 F5-6.3 :occhiali:

Follow me on Flickr: https://www.flickr.c...tos/davideeos86
 


#12 giangi68

giangi68

    Senior Member

  • Gold Member
  • 143 messaggi

Inviato 18 gennaio 2018 - 09:02

salve

premetto che il problema che ho è su ts2010 ma non volevo aprire un nuovo post, visto che è simile

 

stavo usando ts2010 , ma è andata via la luce...!!!

 

da quel momento (3 gg fa) se cerco di entrare nel gioco parte un db repair, sta li le ore, una volta finito si apre e qualsiasi cosa faccio si blocca. se invece apro il content manager vedo i processi in esecuzione e basta.

 

Ho provato a lanciare da prompt il comando trainzutil.exe ha fatto quello che doveva ma non è cambiato nulla

 

qualcuno ha qualche idea o santo a cui votarsi ??

 

aggiungo che prima di saltare la luce funzionava tutto perfettamente

 

grazie a tutti dell' aiuto


WIN 7 64 bit + TS2010 44088 + TS2012 sp1 :su:


#13 pegaso52

pegaso52

    Cab Mode

  • Gold Member
  • 3022 messaggi
  • LocationGranducato di Toscana o meglio FEDERAZIONE ETRUSCA

Inviato 18 gennaio 2018 - 09:15

1) Aprendo il CM ti dice gli oggetti installati se si vedi se ci sono Md e prova a eliminarle dal DB o scaricado le dipendenze mancanti o salvandol gli oggetti in CDP che poi man mano potrai installare.

 

Sei sicuro che sia stata una mancanza di corrente e non ci sia un aggiornamento del SO.


Pier Luigi Kuid 519059
TS 10 Build 49933
TS 12+SP1 Build 61388 Collectors' edition n° 970
T:ANE CE SP3 Build 94916
TRS 2019 Build 97556


#14 gigimori

gigimori

    apprendista stregone

  • Gold Member
  • 1419 messaggi
  • LocationPiacenza

Inviato 18 gennaio 2018 - 09:24

per le mie questioni qui sopra (abbastanza diverso il problema...) ho migliorato eliminando un bel pò di salvataggi obsoleti e inutili di lavori in corso; in questo modo ora il validate ci mette molto meno.

 

Poi, come diceva Pegaso qui sopra al post 4 ho esportato un tot di cdp "importanti" e poi ho eliminato quegli oggetti (per poi reinstallarli ad uno ad uno); la situazione è migliorata.


kuid:184123 - TS12 SPK1 Build 59009 (e rimane tale...)




0 utente(i) stanno leggendo questa discussione

0 utenti, 0 visitatori, 0 utenti anonimi